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Final Cut Pro X Editing Workflow

1. Plan what you want to do       
2. Get organized before you start       
3. Gather your media      
4. Build your story in the Timeline      
5. Organize your story       
6. Trim your story      
7. Add transitions       
8. Add text and graphics       
9. Polish your audio (audio repair and mix)       
10. Adjust your color (color correctionand grading)     
11. Share (Export) your finished project for web, computer, or DVD      
12. Archive your project     

Courtesy Larry Jordan; www.larryjordan.biz

First, a little housekeeping: When importing footage and other content into Final Cut Pro, it 
should be placed within your library. If you don’t have a library, you’ll need to create one. Once 
created, all of your content for all of your shoots and projects will need to go inside that same 
library. Each individual user should have their own library.

Your library will contain all of your events, 
which are containers that hold clips, 
photos, audio files, etc. for use in your 
projects. Projects themselves are also 
kept inside events. 

Think of it this way: An old school file 
cabinet (your library) holds drawers 
(your events) of raw video clips, photos, 
and similar items. Within those drawers, 
there are file folders, which hold a group 
of items placed together in a deliberate 
sequence (your project), which is the 
story told by assembling those video 
clips, photos, transitions, and other 
elements in a coherent and attractive 
order. 

This project, in the form of a video file, is 
what is shared (exported) for use on 
YouTube or Vimeo, on a DVD, on 
someone’s computer, or, in our case, 
played on CAPS Channel 6 for our community to view.
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To create a new library: In Final Cut Pro, choose File > New > Library.

Within the dialog box that appears, enter the 
name of your library in the Save As box. Use 
your name or a specific title including your 
name so that you and other users will know 
who owns the library. Be sure to specify the 
external hard drive checked out to you as the 
location where the library is placed. (As a 
reminder, never place your library on the 
internal drive of the iMac, as libraries left on 
the iMacs will be deleted.)

Your library will open for use in Final Cut Pro.

To open your previously created library: Choose File > Open > Library > Other or press Cmd O.  
 

If your library is listed in the Open 
dialog box, click once on the library 
name and click Open. Your library will 
open for use in Final Cut Pro. 
 
 
 
 
 
 
 
 

If your library is not listed in the Open dialog 
box, click on the Locate button in the bottom 
left hand corner and navigate to the external 
hard drive, click on the appropriate library, 
and click Open. Your library will open for use 
in Final Cut Pro.
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To import footage or media from a device, camera or archive: Click the Media Import 
button or click File > Import > Media or press Cmd i. 

Select the device 
that is carrying the content to be 
imported; in this example, the 
SDHC card is named GOPRO1 in 
the sidebar.

When selected, available 
clips will show in the 
browser; clicking on any 
one will show them in 
the viewer.

Once a device is 
selected in the sidebar, you may 
view clips in either Filmstrip or 
List view.

Select some or all of the clips for import. This is where the 
edit process actually begins-we may not need or want all 
of the clips that were recorded. Select the ones you want. 
In the Import Options box, select Add to existing event and 
choose the event in which you want to add the clips. If you 
just created a library, your event will be today’s date. The 
event name can be changed later to represent what the 
event contains.

Make sure Copy to library is selected. Some file formats 
give you a choice, but in any case, you want all files to be 
imported into the event. 

Click Import All/Import Selected. Do this with all footage 
you wish to import.
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Once your footage is imported, a project will need to be created. To create a project: Click File > New > 
Project or press Cmd N.

A dialog box will ask for the project name, to which event it is to be attached, and other options.

If your footage has been recorded with CAPS cameras set at 720p60 settings, you may enter an 
appropriate project title and press OK. If you are not sure or want to view the settings you should use in 
your project timeline, click Use Custom Settings. The proper settings for shooting, editing, and playback 
files at CAPS are HD 1280 x 720 Progressive 59.94fps with audio at 48k ProRes 422. Click OK.
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A new project, “Untitled Project,” appears in the Event browser and the project storyline shows the 
same title, This project is where we will place our video clips, audio clips, graphics, transitions, and 
other elements to tell the story. We can change the name of the project by clicking in the title in the 
Event window and typing a new name.

Now the editing process takes flight. We are going to select the sections of clips we wish to use and 
place them in the project’s primary storyline. Here’s how to do this: While the event is selected in the 
sidebar, move the mouse over a clip. A red line appears at the mouse pointer and on the viewer, we can 
see the video representation of where that pointer, or playhead, is. To view a clip, skim with the mouse 
or move the mouse over any clip and press the spacebar to start or stop playback. 

To select a portion of the clip to 
be added to the project, at the 
point of your choosing, click 
and hold down the mouse 
while moving the mouse to the 
right. Release the mouse 
button where you want the clip 
to end.

While the clip selection is 
highlighted (yellow), press the 
letter E or move the mouse 
over the highlighted section, 
and click, drag, and drop it into the storyline below.
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Continue to add clips to the storyline until all desired clips are present. To add photos or music, import 
the elements into your event and edit into the project’s storyline. This is your rough cut.

Other editing functions beyond Append Edit (e) include Insert Edit (w), Connect Edit (q), and Overwrite 
Edit (d).You may rearrange or drag clips into any order as Final Cut Pro’s Magnetic Timeline will allow 
you to move clips backward or forwards while allowing inserts or closing gaps as necessary.

Press Shift z to zoom to fit the timeline to the window. Pressing Cmd = or Cmd - zooms in or out. To 
adjust clip appearance including height, clip viewing, and audio waveform preferences, click and adjust 
at the bottom right of the Final Cut Pro window. These same settings are also available in the Events 
viewer window.
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To lengthen or shorten clips in the timeline, zoom in using Cmd  = and place your pointer over the end 
of a clip. When the pointer turns to the Ripple Trim tool, a bracket-like tool, click and drag to extend or 
shorten clips. You will want to trim as necessary to cut your project very tightly, meaning you don't want 
any extra, unnecessary footage in the project. 

Some other helpful tips: Use the left and right arrow keys to move left or right one frame at a time, Shift 
arrow keys to move 10 frames left or right, or up and down arrow keys to move to next or previous edit 
points. Snapping (N) is useful and can be turned off or on by toggling the N key.

You may replace a clip by dragging a new clip on to the top of the existing clip. You will be presented 
with several choices: Replace, Replace from Start, Replace from End, and more. If you simply wish to 
swap clips, use Replace. If you wish to replace the existing clip with the new clip but keep the existing 
timing without changing the length of the project, use Replace from Start (using new footage from the 
front for the length of the old clip) or Replace from End (using new footage from the tail for the length of 
the old clip).

Once the rough cut storyline is trimmed, you may begin adding music, transitions, graphics, lower 
thirds, and other effects to enhance your story. Here’s how to do it:

Click on the Effects tab in the right center of the 
window to show or hide the Effects tab. Preview 
any effect by hovering the mouse over the effect. 
Click, drag, and drop the desired effect on top of 
the clip to which the effect is being added.

Click on the Transitions tab in the right center of the 
window to show or hide the Transitions tab. Preview 
any transition by hovering the mouse over the 
transition. Click, drag. and drop the desired transition 
between the clips to add the transition.
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Click on the Text tab in the right center of the window to 
show or hide the Text tab. Preview any Text elements 
by hovering the mouse over the transition. Click, drag, 
and drop the desired Text element to the desired 
location in the storyline.

Click on the Generators tab in the right center of 
the window to show or hide the Generators tab. 
Preview any Generator element by hovering the 
mouse over the Generator. Click, drag, and drop 
the desired Generator element to the desire 
location in the timeline.

To use the Inspector to modify any parameter of the clip or other 
item, click the Inspector button. The Inspector button turns blue 
and the Inspector appears in the upper right of the Final Cut Pro 
window. 

The Inspector is a contextual window and displays 
information relevant to whatever item you have selected. 
Click on the Video, Audio, Info, or other tab as desired to 
display and modify information for the selected item.
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Edit into the timeline a Generator Gap (Option w) at the beginning of the timeline and again at the end 
of the storyline. Click on the edit point between the gap and the first clip and insert a Basic Transition 
(Cmd t) and repeat this step at the edit point between the last clip and the gap. Trim with the Ripple 
Trim tool so each gap is only 1 second long before the transition starts at the top or after the transition 
ends at the tail of the clip.

Audio is a very important part of video editing. It’s best to check audio levels throughout the entire 
project and make sure levels are not too high, which is bad, or too low, which is hard to hear. Each clip 
should be adjusted to the right level of audio signal. Move the mouse over the audio waveforms (which 
must be showing to adjust in the timeline) and when the pointer turns to arrows pointing up and down, 
click and drag the level up or down. Correct levels for overall volume at CAPS are between -12 and -6. 
Audio levels should never exceed -6. If you see lots of yellow or any red, it’s TOO LOUD and must be 
lowered. The example on the left show appropriate levels while the one on the right shows excessive 
levels and needs to be adjusted to a lower level.
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When the project is completed, it’s time to share (or export) it so that it can be viewed by others. There 
are several options with regard to output choices. The format for content to be played back on CAPS’ 
Channel 6 is different than that which is to be uploaded to YouTube, Vimeo, or other online video 
players, which is also different from requirements for viewing on a DVD player.

To export a file for CAPS playback, click the Show Share 
Destinations button on the far right of the window and select 
CAPS Playback or click File > Share > CAPS Playback from 
the menu.

Click Next. In the dialog box that opens, confirm the name is 
what you want to use, select a location where the file is to be 
saved, and click Save. Your exported file will be exported to the 
location you chose.
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Export progress is 
displayed in the center of 
the application window as 
the file is exported. 

Click on the Show/Hide  
Background Tasks toggle to view 
the Background Tasks window. Click 
again to hide the window.

Be sure to allow the export process 
to complete. When finished, this file 
can be copied to a flash drive and 
submitted to CAPS for playback, 
along with a completed and signed 
Cablecast Request form. This video 
file is the preferred format and DVDs 
are no longer a necessary or 
desired manner to submit a show. 

To export a web-ready file for YouTube, Vimeo, or other online 
video playback system, select CAPS Web and follow the same 
steps as above. Copy your file to a flash drive to take home and 
upload. CAPS does not provide internet access to upload files.

In order to burn a DVD, 
you’ll need to request a 
DVD drive from CAPS 
Staff, as they are no 
longer built into the iMac.
To burn a DVD, click the 
Show Share Destinations 
buttons and select DVD 
or click File > Share > 
DVD from the menu. 
Insert a blank DVD-R disc 
when required. Click 
Burn. Your disk will eject 

when completed.
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Available Resources:

Apple Final Cut Pro X Help Files available on all Final Cut Pro X edit bays           
           

DeWolfe Music Library available in CAPS’ main area           

Apple Pro Training Series v10.1 books available, related video training materials on all Final Cut            
Pro X edit bays           

Offsite Web-based training, no cost: search online for FCPX training, including YouTube            
(internet access not available at CAPS)           

           
Offsite Web-based training, fee-based: Larry Jordan.biz, RippleTraining.com, Lynda.com           
(internet access not available at CAPS)           
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